返回顶部

收藏

ruby 查询 QQwry.dat ip 库的 IpLocationSeeker 类

更多
#!/usr/bin/env ruby
# -*- coding: utf-8 -*-
#

require 'rubygems'
#gem install qqwry
require 'qqwry'

$fqqwry='qqwry.dat'
unless File.exist? $fqqwry
  d = File.dirname __FILE__
  $fqqwry = File.join d, $fqqwry
  unless File.exist? $fqqwry
    p $fqqwry + ' not found '
  end
end

class IpLocationSeeker
  def seek(ip) #查询IP
    unless File.exist? $fqqwry
      return ''
    end

    db = QQWry::Database.new $fqqwry
    r = db.query(ip)
    "#{r.country} #{r.area}"
  end
end
class String
  @@last_area ||={}
  def area
    if @@last_area.size > Time.now.year
      @@last_area.clear
    end
    if @@last_area.has_key? self
      return @@last_area[self]
    else
      @@last_area[self]= IpLocationSeeker.new.seek self
    end
    return @@last_area[self]
  end
end

if __FILE__ == $0
  if ARGV[0]
    p IpLocationSeeker.new.seek ARGV[0]
  else
    p IpLocationSeeker.new.seek '8.8.8.8'
  end
end

标签:ruby

收藏

0人收藏

支持

0

反对

0

相关聚客文章
  1. 博主 发表 2017-10-05 17:30:45 Lion使用RVM安装ruby
  2. xinlu 发表 2017-10-27 01:35:11 nginx+unicorn部署方案
  3. xinlu 发表 2017-10-21 09:35:08 nginx反向代理tomcat提示13 permission denied while connec
  4. 博主 发表 2017-10-10 00:00:00 Ruby 2.5.0-preview1 Released
  5. admin 发表 2017-10-16 16:00:00 Now, you can monitor, debug and log your Ruby apps
  6. coder4 发表 2017-10-09 09:22:32 [转]rvm 用于ruby版本的管理
  7. xinlu 发表 2017-10-05 00:55:03 Install Ruby on Rails with RVM on CentOS 7
  8. 博主 发表 2017-09-14 00:00:00 Ruby 2.4.2 Released
  9. 博主 发表 2017-09-14 12:00:00 Ruby 2.2.8 Released
  10. 博主 发表 2017-09-14 12:00:00 Ruby 2.3.5 Released
  11. xinlu 发表 2017-09-08 06:47:58 ruby的路由配置
  12. xinlu 发表 2017-09-11 07:12:29 Angular安装教程及npm使用淘宝镜像

发表评论