使用Cocoapods的iOS Analytics 3.17 for iOS现在支持Bitcode吗?

使用Cocoapods的iOS Analytics 3.17 for iOS现在支持Bitcode吗?,第1张

概述我刚刚注意到Google Analytics for iOS(3.17)的更新,我想知道切换到使用此 Cocoapod( https://cocoapods.org/pods/GoogleAnalytics)是否安全并且它现在是否正确支持Bitcode?之前有过这些Cocoapods的问题. 具体来说,我已经在我的应用程序中使用谷歌分析3.15几个月了,但我没有使用过Cocoapod,因为它没有为 我刚刚注意到Google Analytics for iOS(3.17)的更新,我想知道切换到使用此 Cocoapod( https://cocoapods.org/pods/GoogleAnalytics)是否安全并且它现在是否正确支持Bitcode?之前有过这些Cocoapods的问题.

具体来说,我已经在我的应用程序中使用谷歌分析3.15几个月了,但我没有使用过Cocoapod,因为它没有为我编译(谷歌不支持Bitcode for iOS的Cocoapod版本的代码,如果我没记错的话).在某个地方,我通过直接下载GoogleAnalytiCSServices库(https://developers.google.com/analytics/devguides/collection/ios/v3/sdk-download)并将其拖入我在Xcode的项目中,它会工作,并支持Bitcode.它有它,并且一直运作良好.

但是现在我想通过Cocoapods进行升级和转换,如果它支持Bitcode,并且得到Google的正式支持.

谁知道?

谢谢.

PS.哪个版本?

谷歌称使用Cocoapod命名:

pod’Google / Analytics’

(https://developers.google.com/analytics/devguides/collection/ios/v3/?ver=swift)

在Cocoapods.org上,Google表示要使用这个:

pod’GoogleAnalytics’

(https://cocoapods.org/pods/GoogleAnalytics)

哪个版本使用正确?

解决方法 在您的iOS应用中实施Google Analytics时,应使用Google / Analytics广告连播. GoogleAnalytics pod不适合直接使用;我们将更新广告连播说明. 总结

以上是内存溢出为你收集整理的使用Cocoapods的iOS Analytics 3.17 for iOS现在支持Bitcode吗?全部内容,希望文章能够帮你解决使用Cocoapods的iOS Analytics 3.17 for iOS现在支持Bitcode吗?所遇到的程序开发问题。

如果觉得内存溢出网站内容还不错,欢迎将内存溢出网站推荐给程序员好友。

欢迎分享,转载请注明来源:内存溢出

原文地址:http://outofmemory.cn/web/1047328.html

(0)
打赏 微信扫一扫微信扫一扫 支付宝扫一扫支付宝扫一扫
上一篇 2022-05-25
下一篇2022-05-25

发表评论

登录后才能评论

评论列表(0条)

    保存