(1)掌握点到多点子接口配置
(2)实现跨网络连通
二、实验仪器设备及软件
四台路由器
软件:Cisco Packet Tracer Student
三、实验原理
//在端口封装frame-relay协议 #encapsulation frame-relay
//设置子接口s1/0.1复用端口 #int s1/0.1 multipoint
#ip add 192.168.0.2 255.255.255.0
//设置静态路由 #frame-relay map ip 192.168.0.2 102 broadcast
//设置动态路由 #frame-relay interface-dlci 103
//设置子接口s1/0.2点对点端口 #int s1/0.2 point-to-point
#ip add 172.16.0.1 255.255.255.0
#frame-relay interface-dlci 104
四、实验内容与步骤
(1)网络拓扑
(2)设置路由器帧中继封装协议
A.中心路由器
Router0(config)#int s1/0
Router0(config-if)#encapsulation frame-relay
//在端口封装frame-relay协议
Router0(config-if)#no shu
Router0(config)#int s1/0.1 multipoint
//设置子接口s1/0.1复用端口
//用复用端口是因为有两个192.168.0.0 网段的远端路由器
Router0(config-subif)#ip add 192.168.0.1 255.255.255.0
Router0(config-subif)#frame-relay map ip 192.168.0.2 102 broadcast
//设置静态路由
Router0(config-subif)#frame-relay interface-dlci 103
//设置动态路由
Router0(config)#int s1/0.2 point-to-point
//设置子接口s1/0.2点对点端口
//使用理由同上
Router0(config-subif)#ip add 172.16.0.1 255.255.255.0
Router0(config-subif)#frame-relay interface-dlci 104
Router0(config-subif)#
B.远端路由器
Router1(config)#int s1/0
Router1(config-if)#ip add 192.168.0.2 255.255.255.0
Router1(config-if)#frame-relay interface-dlci 104
Router1(config-if)#encapsulation frame-relay
Router1(config-if)#no shu
Router2(config)#int s1/0
Router2(config-if)#ip add 192.168.0.3 255.255.255.0
Router2(config-if)#encapsulation frame-relay
Router2(config-if)#no shut
Router3(config)#int s1/0
Router3(config-if)#ip add 172.16.0.2 255.255.255.0
Router3(config-if)#encapsulation frame-relay
Router3(config-if)#no shut
(3)配置动态路由
Router0(config-router)#net 192.168.0.0
Router0(config-router)#net 172.16.0.0
Router0(config-router)#
Router1(config)#router rip
Router1(config-router)#net 192.168.0.0
Router2(config)#router rip
Router2(config-router)#net 192.168.0.0
Router3(config)#router rip
Router3(config-router)#net 172.16.0.0
//不配置路由的话,不同网段无法ping通
(4)配置Cloud0
//一定要记得配置cloud
五、实验结果与分析
(4)互通测试
A.Router0
Router0#ping 192.168.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Router0#ping 192.168.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.3, timeout is 2 seconds:
!!!!!
Router0#ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
B.Router1
Router1#ping 192.168.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Router1#ping 192.168.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.3, timeout is 2 seconds:
!!!!!
Router1#ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Router1#ping 172.16.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
C.Router2
Router2#ping 192.168.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Router2#ping 192.168.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Router2#ping 172.16.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
Router2#ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Router3#ping 192.168.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
D.Router3
Router3#ping 192.168.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
Router3#ping 192.168.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.3, timeout is 2 seconds:
!!!!!
Router3#ping 172.16.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
!!!!!
打开CSDN,阅读体验更佳
CCNA配置试验之九 帧中继——点到多点(point-to-multipoint)子接口...
r1(config-if)#no frame-relay inverse-arp关闭帧中继的反向ARP功能 r1(config-if)#exit r1(config)#int s0/0.1 multipoint配置点到多点的frame-relay r1(config-subif)#ip addr 192.168.1.1 255.255.255.0 r1(config-subif)#no ...
CCNA之ccna-路由器的帧中继点到多点配置试验_weixin_34297704的博客-CSDN...
在帧中继下划分子接口可以解决水平分割造成的问题。一个物理端口可以被划分成多个逻辑意义上的子端口。 多点子接口:所有接入的接口都处于同一的子网中,所有接口共享同一网段。 拓扑如下: 我们来实现R1-R2-R3-R4间ping通,而R2-R3-R4间...
最新发布 计算机网络:帧中继的概念
*帧中继(FrameRelay)
继续访问
CCNA配置试验之九 帧中继——点到多点(point-to-multipoint)子接口配置
上篇博文中我们试验验证了,帧中继point-to-point。今天我们来验证帧中继的point-to-multipoint。 试验拓扑如下: 试验拓扑说明:(拓扑做的有点烂,大家多担待点 。呵呵) 试验拓扑说明:R1的物理接口不添加IP。R1的子接口S0/0.1的ip为192.168.1.1。R2的ip为192.168.1.2。R3的ip为192.168.1.3 。...
继续访问
CCNA之ccna-路由器的帧中继点到点配置试验_weixin_34270865的博客-CSDN...
前面我们谈了帧中继的点到多点的配置实验,今天我们来看看点到多点是如何配置的,先来看看实验程序我们可以让R1、R2间ping通,R1、R3间ping通,但是R2、R3间是ping不通的。下面是我们的拓扑图:点到点子接口:子接口看做是专线,每个子...
帧中继 点到多点配置(GNS3)_weixin_33889245的博客
学习CCNP也有一个多月了,这次回过头来捡忘记了的frame-relay 可以看到FR为R2,要实现其中的每一台DTE可以ping通其余2台DTE,首先就是要在FR上把虚电路(PVC)建好。 R2: frame-relay switching 设置成为帧中继交换机 interface Serial0/...
CCNA实验三十 帧中继点到多点子接口
CCNA实验三十 帧中继点到多点子接口环境: Windows XP、 GNS3.0.7.2目的:了解帧中继的点到多点子接口的应用。说明:其实帧中继的点到多点子接口与普通帧中继是一样的,同样会产生水平分割问题。与点对点子接口的区别在于,点对点子接口的不同子接口属于不同子网,而多点子接口属于相同子网。步骤: GNS创建如下拓扑:配置FR:Router>enRouter#conf tRouter(config)#Host FRFR(config)#frame-relay s
继续访问
多点子接口的帧中继配置(MP SubInterface FrameRealy)
实验来源:工大瑞普Cisco网络技术论坛 注:这个实验同样出现了上个实验所出现的问题,配置好后,接口怎么都起不来,不管它,过了10分钟左右自己莫名其妙的UP起来。郁闷!还是仅把配置贴出来。。 R1配置: Router#show run Building configuration... Current configuration : 1031 by...
继续访问
BSCI实验之十五:OSPF在帧中继点到多点模式下的配置_weixin_34074740的博...
实验目的:接口静态映射、点到多点模式特征、配置和调试。 一、帧中继交换机配置 在R1上进行如下配置 hostname FRS frame-relay switching interface Serial1/0 no ip address encapsulation frame-relay ---接口封装为帧中继 ...
帧中继多点子接口
试验目的:帧中继多点子接口配置方式连通全网。 试验设备:r1、r2、r3、vpcs。 注意:这里因为都只用了一个子接口,所以ip地址分配因改为 r1s0/0.10:10.0.0.1 r2s0/0.10:10.0.0.2 r3s0/0.10:10.0.0.3)原s0/0口分配的ip均不使用。 (在网易博客看到这个配置有错,在这里稍作修改。) 到此帧中继多...
继续访问
多点子接口的帧中继配置
实验来源:工大瑞普Cisco网络技术论坛 注:这个实验同样出现了上个实验所出现的问题,配置好后,接口怎么都起不来,不管它,过了10分钟左右自己莫名其妙的UP起来。郁闷!还是仅把配置贴出来。。R1配置: Router#show runBuilding configuration...Current configuration : 1031 bytes!version...
继续访问
帧中继环境下的点到多点的配置
帧中继环境下的点到多点的配置 1、 实验目的: 通过本次的实验,我们可以掌握如下技能 1) 帧中继子接口下的静态映射 2) 点到多点模式的特征 3) 点到多点模式下OSPF的配置和调试 2、 实验拓扑图: 3、 实验步骤: (1) 路由器R1的配置 R1(c...
继续访问
帧中继多点子接口上运行EIGRP_实验
1.禁用水平分割的影响 2.让R2\R3能够通信 3.让R2\R3建立邻居关系 1.在路由器R1的多点子接口上禁用EIGRP水平分割,能使得与R2\R3路由器连接的网络之间通信 2.动态映射不提供让路由器R2与R3相互通信的动态映射,需要手动添加这种映射 3. 对R2:frame-relay map ip 192.168.1.101 100 br 对R3:frame-
继续访问
eNSP关于多点子接口和点到点子接口实例
eNSP关于多点子接口和点到点子接口实例:点到点子接口:R1到R2多点子接口:R1到R3、R4关键配置:[R1]dis cursysname R1#router id 91.1.1.1#interface Serial0/0/0link-protocol frundo fr inarp#...
继续访问
帧中继多点子接口、单点子接口配置试验
拓扑图如下:首先做下帧中继交换机的配置:FRSwitch:frame-relay switchinginterface s1/0encapsulation frame-relayno shutframe-relay intf-type dceframe-relay lmi-type ciscoclock rate 64000interface s1/1encapsulatio...
继续访问
子接口实现帧中继
实验拓扑图如下: 实验步骤 (一)、基本信息配置 (1)、RT1的基本信息配置: RT1-FRSW#enable RT1-FRSW#conf t Enter configuration commands, one per line.End with CNTL/Z. RT1-FRSW(config)#hostname RT1-FRSW...
继续访问
FR帧中继(点对点子接口)
帧中继配置(点对点子接口模式) 一、基本信息配置(略) 二、配置命令 两种模式(点对点子接口模式、NBMA主接口模式) Frame-Relay点对点子接口模式:如图 实验中,我们需要用RT1路由器来模拟帧中继交换机,所以要打开它的帧中继交换功能。 RT1(FRSW): FRSW(config)#frame-relay...
继续访问
Packet Tracer(第四期)---4帧中继点对点子接口(完)
帧中继点对点子接口–PKA下载地址 目标 第 1 部分:配置帧中继 第 2 部分:配置帧中继点对点子接口 第 3 部分:检验配置和连接 场景 在本练习中,您将在每台路由器上配置两个子接口的帧中继以访问其他两台路由器。您还将配置 EIGRP 并检验端到端连接。 第 1 部分: 配置帧中继 第 1 步: 在 R1 的 S0/0/0 接口上配置帧中继封装。 第 2 步: 在 R2 和 R3 的 S0/0/0 接口上配置帧中继封装。 第 3 步: 测试连通性。 从 PC 上的命令提示符中,使用 ping 命令检
继续访问
配置帧中继子接口和流量整形
配置帧中继子接口和流量整形 第一步:在R1上的预配置 R1(config)#int s3/0 R1(config-if)#en fr在接口下封装帧中继 R1(config-if)#no fram R1(config-if)#no frame-relay inv R1(config-if)#no frame-relay inverse-arp关闭反向A...
继续访问
帧中继多点子接口下配置OSPF
帧中继多点子接口下配置OSPF1、实验目的通过本实验可以掌握A、帧中继多点子接口的特征B、帧中继多点子接口的配置C、NBMA模式下OSPF的配置和调试D、手工配置OSPF邻居E、NBMA模式下的DR选举2、实验拓扑3、实验步骤本实验分别在路由器R1、R3和R4尚创建多点子接口,拓扑结构采用Hub-and-Spoke结构,整个网络运行OSPF路由协议。A.配置路由器R1R1(c...
继续访问
H3C 帧中继子接口
转载于:https://www.cnblogs.com/fanweisheng/p/11168295.html
继续访问
帧中继原理浅析
帧中继技术,在有些时候似乎比较容易让人感到模糊,今天来谈一下它的几个基本概念,DLCI、二层映射以及三种接口类型。一、DLCI 在谈DLCI前,先稍微介绍一下帧中继,帧中继是一种使用了包交换方式的标准的广域网技术。简单来说,就是为用户建立了一条端到端之间的虚拟电路连接,中间经过的帧中继云网络对于用户来说是透明的,用户用起来就感觉跟租用物理专线差不多,但是租用帧中继服务就...
继续访问
帧中继点到点
cisco制造的路由器设备、交换机和其他设备承载了全世界80%的互联网通信,成为硅谷中新经济的传奇,那么你了解Cisco常用的路由器交换机配置命令吗?下面是我整理的一些关于Cisco常用的路由器交换机配置命令的相关资料,供你参考。
Cisco常用的路由器支持的命令:
路由器显示命令:
router#show run 显示配置信息
router#show interface 显示接口信息
router#show ip route 显示路由信息
router#show cdp nei 显示邻居信息
router#reload 重新起动
路由器口令设置:
router>enable 进入特权模式
router#config terminal 进入全局配置模式
router(config)#hostname 设置交换机的主机名
router(config)#enable secret xxx 设置特权加密口令
router(config)#enable password xxb 设置特权非密口令
router(config)#line console 0 进入控制台口
router(config-line)#line vty 0 4 进入虚拟终端
router(config-line)#login 要求口令验证
router(config-line)#password xx 设置登录口令xx
router(config)#(Ctrl+z) 返回特权模式
router#exit 返回命令
路由器配置:
router(config)#int s0/0 进入Serail接口
router(config-if)#no shutdown 激活当前接口
router(config-if)#clock rate 64000 设置同步时钟
router(config-if)#ip address 设置IP地址
router(config-if)#ip address second 设置第二个IP
router(config-if)#int f0/0.1 进入子接口
router(config-subif.1)#ip address 设置子接口IP
router(config-subif.1)#encapsulation dot1q 绑定vlan中继协议
router(config)#config-register 0x2142 跳过配置文件
router(config)#config-register 0x2102 正常使用配置文件
router#reload 重新引导
路由器文件 *** 作:
router#copy running-config startup-config 保存配置
router#copy running-config tftp 保存配置到tftp
router#copy startup-config tftp 开机配置存到tftp
router#copy tftp flash: 下传文件到flash
router#copy tftp startup-config 下载配置文件
ROM状态:
Ctrl+Break 进入ROM监控状态
rommon>confreg 0x2142 跳过配置文件
rommon>confreg 0x2102 恢复配置文件
rommon>reset 重新引导
rommon>copy xmodem: flash: 从console传输文件
rommon>IP_ADDRESS=10.65.1.2 设置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0 设置路由器掩码
rommon>TFTP_SERVER=10.65.1.1 指定TFTP服务器IP
rommon>TFTP_FILE=c2600.bin 指定下载的文件
rommon>tftpdnld 从tftp下载
rommon>dir flash: 查看闪存内容
rommon>boot 引导IOS
静态路由:
ip route 命令格式
router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 静态路由举例
router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 默认路由举例
动态路由:
router(config)#ip routing 启动路由转发
router(config)#router rip 启动RIP路由协议。
router(config-router)#network 设置发布路由
router(config-router)#negihbor 点对点帧中继用。
帧中继命令:
router(config)#frame-relay switching 使能帧中继交换
router(config-s0)#encapsulation frame-relay 使能帧中继
router(config-s0)#fram-relay lmi-type cisco 设置管理类型
router(config-s0)#frame-relay intf-type DCE 设置为DCE
router(config-s0)#frame-relay dlci 16
router(config-s0)#frame-relay local-dlci 20 设置虚电路号
router(config-s0)#frame-relay interface-dlci 16
router(config)#log-adjacency-changes 记录邻接变化
router(config)#int s0/0.1 point-to-point 设置子接口点对点
router#show frame pvc 显示永久虚电路
router#show frame map 显示映射
基本访问控制列表:
router(config)#access-list permit|deny
router(config)#interface default:deny any
router(config-if)#ip access-group in|out defaultut
例1:
router(config)#access-list 4 permit 10.8.1.1
router(config)#access-list 4 deny 10.8.1.0 0.0.0.255
router(config)#access-list 4 permit 10.8.0.0 0.0.255.255
router(config)#access-list 4 deny 10.0.0.0 0.255.255.255
router(config)#access-list 4 permit any
router(config)#int f0/0
router(config-if)#ip access-group 4 in
扩展访问控制列表:
access-list permit|deny icmp [type]
access-list permit|deny tcp [port]
例3:
router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo
router(config)#access-list 101 permit ip any any
router(config)#int s0/0
router(config-if)#ip access-group 101 in
例3:
router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80
router(config)#access-list 102 permit ip any any
router(config)#interface s0/1
router(config-if)#ip access-group 102 out
删除访问控制例表:
router(config)#no access-list 102
router(config-if)#no ip access-group 101 in
路由器的nat配置
Router(config-if)#ip nat inside 当前接口指定为内部接口
Router(config-if)#ip nat outside 当前接口指定为外部接口
Router(config)#ip nat inside source static [p] [port]
Router(config)#ip nat inside source static 10.65.1.2 60.1.1.1
Router(config)#ip nat inside source static tcp 10.65.1.3 80 60.1.1.1 80
Router(config)#ip nat pool p1 60.1.1.1 60.1.1.20 255.255.255.0
Router(config)#ip nat inside source list 1 pool p1
Router(config)#ip nat inside destination list 2 pool p2
Router(config)#ip nat inside source list 2 interface s0/0 overload
Router(config)#ip nat pool p2 10.65.1.2 10.65.1.4 255.255.255.0 type rotary
Router#show ip nat translation
rotary 参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。
overload参数用于PAT 将内部IP映射到一个公网IP不同的端口上。
外部网关协议配置
routerA(config)#router bgp 100
routerA(config-router)#network 19.0.0.0
routerA(config-router)#neighbor 8.1.1.2 remote-as 200
配置PPP验证:
RouterA(config)#username password
RouterA(config)#int s0
RouterA(config-if)#ppp authentication {chap|pap}
3.PIX防火墙命令
Pix525(config)#nameif ethernet0 outside security0 命名接口和级别
Pix525(config)#interface ethernet0 auto 设置接口方式
Pix525(config)#interface ethernet1 100full 设置接口方式
Pix525(config)#interface ethernet1 100full shutdown
Pix525(config)#ip address inside 192.168.0.1 255.255.255.0
Pix525(config)#ip address outside 133.0.0.1 255.255.255.252
Pix525(config)#global (if_name) natid ip-ip 定义公网IP区间
Pix525(config)#global (outside) 1 7.0.0.1-7.0.0.15 例句
Pix525(config)#global (outside) 1 133.0.0.1 例句
Pix525(config)#no global (outside) 1 133.0.0.1 去掉设置
Pix525(config)#nat (if_name) nat_id local_ip [netmark]
Pix525(config)#nat (inside) 1 0 0
内网所有主机(0代表0.0.0.0)可以访问global 1指定的外网。
Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0
内网172.16.5.0/16网段的主机可以访问global 1指定的外网。
Pix525(config)#route if_name 0 0 gateway_ip [metric] 命令格式
Pix525(config)#route outside 0 0 133.0.0.1 1 例句
Pix525(config)#route inside 10.1.0.0 255.255.0.0 10.8.0.1 1 例句
Pix525(config)#static (inside, outside) 133.0.0.1 192.168.0.8
表示内部ip地址192.168.0.8,访问外部时被翻译成133.0.0.1全局地址。
Pix525(config)#static (dmz, outside) 133.0.0.1 172.16.0.8
中间区域ip地址172.16.0.8,访问外部时被翻译成133.0.0.1全局地址。
Cisco常用的交换机支持的命令:
交换机基本状态:
switch: ROM状态, 路由器是rommon>
hostname>用户模式
hostname# 特权模式
hostname(config)# 全局配置模式
hostname(config-if)# 接口状态
交换机口令设置:
switch>enable 进入特权模式
switch#config terminal 进入全局配置模式
switch(config)#hostname 设置交换机的主机名
switch(config)#enable secret xxx 设置特权加密口令
switch(config)#enable password xxa 设置特权非密口令
switch(config)#line console 0 进入控制台口
switch(config-line)#line vty 0 4 进入虚拟终端
switch(config-line)#login 允许登录
switch(config-line)#password xx 设置登录口令xx
switch#exit 返回命令
交换机VLAN设置:
switch#vlan database 进入VLAN设置
switch(vlan)#vlan 2 建VLAN 2
switch(vlan)#no vlan 2 删vlan 2
switch(config)#int f0/1 进入端口1
switch(config-if)#switchport access vlan 2 当前端口加入vlan 2
switch(config-if)#switchport mode trunk 设置为干线
switch(config-if)#switchport trunk allowed vlan 1,2 设置允许的vlan
switch(config-if)#switchport trunk encap dot1q 设置vlan 中继
switch(config)#vtp domain 设置发vtp域名
switch(config)#vtp password 设置发vtp密码
switch(config)#vtp mode server 设置发vtp模式
switch(config)#vtp mode client 设置发vtp模式
交换机设置IP地址:
switch(config)#interface vlan 1 进入vlan 1
switch(config-if)#ip address 设置IP地址
switch(config)#ip default-gateway 设置默认网关
switch#dir flash: 查看闪存
交换机显示命令:
switch#write 保存配置信息
switch#show vtp 查看vtp配置信息
switch#show run 查看当前配置信息
switch#show vlan 查看vlan配置信息
switch#show interface 查看端口信息
switch#show int f0/0 查看指定端口信息
欢迎分享,转载请注明来源:内存溢出
评论列表(0条)