杭电1014(JAVA版)

杭电1014(JAVA版),第1张

杭电1014(JAVA版)
Uniform Generator Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42170    Accepted Submission(s): 16615

  Problem Description Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.     Input Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).     Output For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.     Sample Input 3 5 15 20 63923 99999 Sample Output          3                 5     Good Choice         15              20     Bad Choice      63923     99999     Good Choice

一开始是想用数组来一个一个验证是否有0~MOD-1的数字,但是这个方法太笨了,而且耗时太久了。

 想了好久大概推出一个规律,它们必须互为素数,这样子一切都简单了。

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		while(scanner.hasNext()) {
			int STEP=scanner.nextInt();
			int MOD=scanner.nextInt();
			int min=Math.min(STEP, MOD);
			int max=Math.max(STEP, MOD);
			int mod=0;
			do {
				mod=max%min;
				max=min;
				min=mod;
			} while (mod!=0);
			if(max==1) {
				System.out.printf("%10d%10d    Good Choicenn",STEP,MOD);
			}
			else {
				System.out.printf("%10d%10d    Bad Choicenn",STEP,MOD);
			}
		}
		scanner.close();
	}
}

但是又出现了新问题,提示:Presentation Error,输出格式感觉没毛病啊!搜了挺多没有搜到Java代码的,搜到的C++的也是两个n,只好先放着了。希望有看到的大佬帮忙解答一下吧。

欢迎分享,转载请注明来源:内存溢出

原文地址: http://outofmemory.cn/zaji/4669235.html

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
上一篇 2022-11-06
下一篇 2022-11-06

发表评论

登录后才能评论

评论列表(0条)

保存