杭电oj2123(JAVA

杭电oj2123(JAVA,第1张

杭电oj2123(JAVA

Problem Description

In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.

Input

The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.

Output

For each test case, print out the multiply table.

Sample Input

 

2 1 4

Sample Output

 

1 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()) {

			int c=sc.nextInt();
			while(c-->0){

				int n=sc.nextInt();

				for (int i = 1; i <= n; i++) {
					for (int j = 1; j <= n; j++) {

							if (j 

欢迎分享,转载请注明来源:内存溢出

原文地址: https://outofmemory.cn/zaji/5608204.html

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
上一篇 2022-12-15
下一篇 2022-12-15

发表评论

登录后才能评论

评论列表(0条)

保存