Python L1-063 吃鱼还是吃肉 (10 分)

Python L1-063 吃鱼还是吃肉 (10 分),第1张

Python L1-063 吃鱼还是吃肉 (10 分)

 

国家给出了 8 岁男宝宝的标准身高为 130 厘米、标准体重为 27 公斤;8 岁女宝宝的标准身高为 129 厘米、标准体重为 25 公斤。

现在你要根据小宝宝的身高体重,给出补充营养的建议。

输入格式:

输入在第一行给出一个不超过 10 的正整数 N,随后 N 行,每行给出一位宝宝的身体数据:

性别 身高 体重

其中性别是 1 表示男生,0 表示女生。身高和体重都是不超过 200 的正整数。

输出格式:

对于每一位宝宝,在一行中给出你的建议:

  • 如果太矮了,输出:duo chi yu!(多吃鱼);
  • 如果太瘦了,输出:duo chi rou!(多吃肉);
  • 如果正标准,输出:wan mei!(完美);
  • 如果太高了,输出:ni li hai!(你厉害);
  • 如果太胖了,输出:shao chi rou!(少吃肉)。

先评价身高,再评价体重。两句话之间要有 1 个空格。

输入样例:
4
0 130 23
1 129 27
1 130 30
0 128 27

结尾无空行

输出样例:
ni li hai! duo chi rou!
duo chi yu! wan mei!
wan mei! shao chi rou!
duo chi yu! shao chi rou!

结尾无空行

n=int(input())

for i in range(n):
    a=list(map(int,input().split()))
    s=a[0]
    h=a[1]
    w=a[2]

    if s==1:
        if h<130 and w<27:
            print("duo chi yu! duo chi rou!")
        elif h<130 and w==27:
            print("duo chi yu! wan mei!")
        elif h<130 and w>27:
            print("duo chi yu! shao chi rou!")
        elif h==130 and w<27:
            print("wan mei! duo chi rou!")
        elif h==130 and w==27:
            print("wan mei! wan mei!")
        elif h==130 and w>27:
            print("wan mei! shao chi rou!")
        elif h>130 and w<27:
            print("ni li hai! duo chi rou!")
        elif h>130 and w==27:
            print("ni li hai! wan mei!")
        elif h>130 and w>27:
            print("ni li hai! shao chi rou!")
    elif s==0:
        if h<129 and w<25:
            print("duo chi yu! duo chi rou!")
        elif h<129 and w==25:
            print("duo chi yu! wan mei!")
        elif h<129 and w>25:
            print("duo chi yu! shao chi rou!")
        elif h==129 and w<25:
            print("wan mei! duo chi rou!")
        elif h==129 and w==25:
            print("wan mei! wan mei!")
        elif h==129 and w>25:
            print("wan mei! shao chi rou!")
        elif h>129 and w<25:
            print("ni li hai! duo chi rou!")
        elif h>129 and w==25:
            print("ni li hai! wan mei!")
        elif h>129 and w>25:
            print("ni li hai! shao chi rou!")

输出结果 

欢迎分享,转载请注明来源:内存溢出

原文地址: http://outofmemory.cn/zaji/5495892.html

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
上一篇 2022-12-12
下一篇 2022-12-12

发表评论

登录后才能评论

评论列表(0条)

保存