分类: 电脑/网络 >> 程序设计 >> 其他编程语言
问题描述:
小弟不才
Problem description
We just test the input and output system in your selected language
Input
The Input will contain only o integers a,b
Output
The Ouput should contains the result of a + b No other whitespace contians at begin or end of the output Notice : empty line is allowed
Sample Input
10 20
Sample Output
30
代码最短57B就可以做到
谢谢大家
解析:
太简单了,题目意思是:输入两个整数,输出它们的和。输出结果的前后都不允许有空格,但可以有空行。
#include <stdioh>
void main()
{int a,b;
scanf("%d%d",&a,&b);
printf("%d\n",a+b);
}
#include<stdioh>
int main()
{
int a,i,j,sum=0;
double eavg;
int b[5],temp;
printf("请输入5个正整数\n");
for(i=0;i<5;i++){
scanf("%d",&b[i]);
sum+=b[i];
}
for(j=0;j<4;j++)
for(i=0;i<4-j;i++)
if(b[i]<b[i+1])
{
temp=b[i];
b[i]=b[i+1];
b[i+1]=temp;
}
printf("1,求和\n2,求平均值\n3,查询最大值\n4,查询最小值\n");
scanf("%d",&a);
switch(a)
{
case 1:
printf("累计和%d\n",sum);
break;
case 2:
eavg=(double)sum/5;
printf("平均值为%f\n",eavg);
break;
case 3:
printf("数组中最大值为%d\n",b[0]);
break;
case 4:
printf("数组中最小值为%d\n",b[4]);
break;
}
for(i=0;i<5;i++)
printf("%d ",b[i]);
return 0;
}
#include <stdioh>
void main()
{
int a=15;
/定义a为整型变量,且值为15/
float b=1231234567;
/定义b为单精度浮点型变量,且值为1231234567/
double c=123456781234567;
/定义c为双精度浮点型变量,且值为123456781234567/
char d='p';
/定义d为字符型变量,且值为p/
printf("a=%d,%5d,%o,%x\n",a,a,a,a);
/整型输出;整形且长度为5输出;八进制输出;十六进制输出/
printf("b=%f,%lf,%54lf,%e\n",b,b,b,b);
/浮点型输出;长浮点型输出;长度为5,小数点后保留4位输出;指数形式输出/
printf("c=%lf,%f,%84lf\n",c,c,c);
/长浮点型输出;浮点型输出;长度为8,小数点后保留4位输出/
printf("d=%c,%8c\n",d,d);
/字符型输出;长度为8,字符型输出/
/长度不足,就会输出空格/
}
以上就是关于几乎最简单的C语言程序(需要一点E文知识)全部的内容,包括:几乎最简单的C语言程序(需要一点E文知识)、一个简单的C语言程序,可以正常运行的。、简单的C程序等相关内容解答,如果想了解更多相关内容,可以关注我们,你们的支持是我们更新的动力!
欢迎分享,转载请注明来源:内存溢出
评论列表(0条)